Discussion:
OpenSMTPd error "io-error: No SSL error"
(too old to reply)
Atanas Vladimirov
2017-11-05 15:17:05 UTC
Permalink
Raw Message
Hello misc,

First, sorry that I'm reporting this issue so late, but I spotted it
before a few days.
It seems that my surveillance webcam stopped to notify me via email with
the following messages in maillog:

========
Nov 5 15:59:34 hodor smtpd[59494]: 2847e02c4337309e smtp
event=connected address=172.16.1.8 host=attic.bsdbg.net
Nov 5 15:59:35 hodor smtpd[59494]: 2847e02c4337309e smtp event=closed
address=172.16.1.8 host=attic.bsdbg.net reason="io-error: No SSL error"
========

The webcam logs the following:

========
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set Root="***@bsdbg.net"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set MailHub="172.16.1.1"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set RemotePort="587"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set RewriteDomain=""
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set HostName="172.16.1.1"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set
AuthUser="***@bsdbg.net"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set AuthPass="Password"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set
FromLineOverride="True"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set UseSTARTTLS="True"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: Set MailHub="172.16.1.1"
Nov 5 14:12:30 attic.bsdbg.net sSMTP[31831]: via SMTP Port Number="587"
Nov 5 14:12:31 attic.bsdbg.net sSMTP[31831]: Creating SSL connection to
host
Nov 5 14:12:31 attic.bsdbg.net sSMTP[31831]: 220 hodor.bsdbg.net ESMTP
OpenSMTPD
Nov 5 14:12:31 attic.bsdbg.net sSMTP[31831]: EHLO 172.16.1.1
Nov 5 14:12:31 attic.bsdbg.net sSMTP[31831]: 250 HELP
Nov 5 14:12:31 attic.bsdbg.net sSMTP[31831]: STARTTLS
Nov 5 14:12:31 attic.bsdbg.net sSMTP[31831]: 220 2.0.0: Ready to start
TLS
Nov 5 14:12:32 attic.bsdbg.net sSMTP[31831]: Cannot open 172.16.1.1:587
Nov 5 14:12:32 attic.bsdbg.net sSMTP[31831]: Can't open //dead.letter
failing horribly!
========

When I checked the logs on the server, last successfully sent message
was on September 10,
just before I moved to a newer snapshot (from Aug 26 to Sep 9):

======
/etc/motd diffs (-OLD +NEW)
======
--- /var/backups/etc_motd.current Mon Aug 28 01:30:39 2017
+++ /etc/motd Sun Sep 10 09:53:39 2017
@@ -1,4 +1,4 @@
-OpenBSD 6.2-beta (GENERIC.MP) #46: Sat Aug 26 12:14:12 MDT 2017
+OpenBSD 6.2-beta (GENERIC.MP) #85: Sat Sep 9 17:44:54 MDT 2017

Here is how a successful delivery looks like:

========
Sep 10 06:56:54 hodor smtpd[41890]: cf24b009186225a0 smtp
event=connected address=172.16.1.8 host=attic.bsdbg.net
Sep 10 06:57:01 hodor smtpd[41890]: cf24b009186225a0 smtp event=starttls
address=172.16.1.8 host=attic.bsdbg.net ciphers="version=TLSv1,
cipher=AES256-SHA, bits=256"
Sep 10 06:57:02 hodor smtpd[41890]: cf24b009186225a0 smtp
event=authentication user=***@bsdbg.net address=172.16.1.8
host=attic.bsdbg.net result=ok
Sep 10 06:57:07 hodor smtpd[41890]: cf24b009186225a0 smtp event=message
address=172.16.1.8 host=attic.bsdbg.net msgid=987a89ab
from=<***@bsdbg.net> to=<***@bsdbg.net> size=47232 ndest=1
proto=ESMTP
Sep 10 06:57:07 hodor smtpd[41890]: cf24b009186225a0 smtp event=closed
address=172.16.1.8 host=attic.bsdbg.net reason=quit
Sep 10 06:57:07 hodor dovecot: lmtp(14906): Connect from local
Sep 10 06:57:07 hodor dovecot: lmtp(***@bsdbg.net): msgid=unspecified:
saved mail to INBOX
Sep 10 06:57:07 hodor dovecot: lmtp(14906): Disconnect from local:
Successful quit
Sep 10 06:57:07 hodor smtpd[41890]: 0000000000000000 mda event=delivery
evpid=987a89ab9622c6e0 from=<***@bsdbg.net> to=<***@bsdbg.net>
user=vmail method=lmtp delay=5s result=Ok stat=Delivered
========

#
### smtpd.conf
#
~$ cat /etc/mail/smtpd.conf
# $OpenBSD: smtpd.conf,v 1.9 2016/05/03 18:43:45 jung Exp $

# This is the smtpd server system-wide configuration file.
# See smtpd.conf(5) for more information.

# pki
pki hodor.bsdbg.net certificate "/etc/ssl/bsdbg.fullchain.pem"
pki hodor.bsdbg.net key "/etc/ssl/private/bsdbg.key"

# tables setup
table aliases file:/etc/mail/aliases
table domains file:/etc/mail/domains
table passwd passwd:/etc/mail/passwd
table virtuals file:/etc/mail/virtuals

# To accept external mail, replace with: listen on all
#
listen on lo0
listen on vether0 port submission tls pki hodor.bsdbg.net auth <passwd>
listen on egress port smtp tls pki hodor.bsdbg.net
listen on egress port submission tls-require pki hodor.bsdbg.net auth
<passwd>

# allow local messages
accept from local for local alias <aliases> deliver to lmtp
"/var/dovecot/lmtp" rcpt-to

# allow virtual domains
accept from any for domain <domains> virtual <virtuals> deliver to lmtp
"/var/dovecot/lmtp" rcpt-to

# allow outgoing mails
accept from local for any relay

Please, let me know if you need more details.

#
### dmesg - Please note that I'm running with this patch [0], that's why
the running kernel was build by me.
#

OpenBSD 6.2-current (GENERIC.MP) #0: Sun Oct 15 18:29:37 EEST 2017
***@hodor.bsdbg.net:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 17132367872 (16338MB)
avail mem = 16606101504 (15836MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xeb5a0 (56 entries)
bios0: vendor American Megatrends Inc. version "2.2" date 02/20/2015
bios0: Thomas-Krenn.AG X9SCL/X9SCM
acpi0 at bios0: rev 2
acpi0: sleep states S0 S1 S4 S5
acpi0: tables DSDT FACP APIC FPDT MCFG HPET SSDT SPMI SSDT SSDT DMAR
acpi0: wakeup devices PS2K(S4) UAR1(S4) UAR2(S4) P0P1(S4) USB1(S4)
USB2(S4) USB3(S4) USB4(S4) USB5(S4) USB6(S4) USB7(S4) PXSX(S4) RP01(S4)
PXSX(S4) RP02(S4) PXSX(S4) [...]
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz, 3300.48 MHz
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
cpu0: 256KB 64b/line 8-way L2 cache
acpitimer0: recalibrated TSC frequency 3300029275 Hz
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 100MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.1, IBE
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz, 3300.02 MHz
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 0, core 1, package 0
cpu2 at mainbus0: apid 4 (application processor)
cpu2: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz, 3300.02 MHz
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 0, core 2, package 0
cpu3 at mainbus0: apid 6 (application processor)
cpu3: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz, 3300.02 MHz
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 0, core 3, package 0
cpu4 at mainbus0: apid 1 (application processor)
cpu4: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz, 3300.02 MHz
cpu4:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
cpu4: 256KB 64b/line 8-way L2 cache
cpu4: smt 1, core 0, package 0
cpu5 at mainbus0: apid 3 (application processor)
cpu5: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz, 3300.02 MHz
cpu5:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
cpu5: 256KB 64b/line 8-way L2 cache
cpu5: smt 1, core 1, package 0
cpu6 at mainbus0: apid 5 (application processor)
cpu6: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz, 3300.02 MHz
cpu6:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
cpu6: 256KB 64b/line 8-way L2 cache
cpu6: smt 1, core 2, package 0
cpu7 at mainbus0: apid 7 (application processor)
cpu7: Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz, 3300.02 MHz
cpu7:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
cpu7: 256KB 64b/line 8-way L2 cache
cpu7: smt 1, core 3, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0 addr 0xe0000000, bus 0-255
acpihpet0 at acpi0: 14318179 Hz
acpihpet0: recalibrated TSC frequency 3300035080 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 7 (P0P1)
acpiprt2 at acpi0: bus 5 (RP01)
acpiprt3 at acpi0: bus -1 (RP02)
acpiprt4 at acpi0: bus -1 (RP03)
acpiprt5 at acpi0: bus -1 (RP04)
acpiprt6 at acpi0: bus 6 (RP05)
acpiprt7 at acpi0: bus -1 (RP06)
acpiprt8 at acpi0: bus -1 (RP07)
acpiprt9 at acpi0: bus -1 (RP08)
acpiprt10 at acpi0: bus 1 (PEG0)
acpiprt11 at acpi0: bus -1 (PEG1)
acpiprt12 at acpi0: bus -1 (PEG2)
acpiprt13 at acpi0: bus -1 (PEG3)
acpiec0 at acpi0: not present
acpicpu0 at acpi0: C3(***@80 ***@0x20), C1(***@1 mwait.1), PSS
acpicpu1 at acpi0: C3(***@80 ***@0x20), C1(***@1 mwait.1), PSS
acpicpu2 at acpi0: C3(***@80 ***@0x20), C1(***@1 mwait.1), PSS
acpicpu3 at acpi0: C3(***@80 ***@0x20), C1(***@1 mwait.1), PSS
acpicpu4 at acpi0: C3(***@80 ***@0x20), C1(***@1 mwait.1), PSS
acpicpu5 at acpi0: C3(***@80 ***@0x20), C1(***@1 mwait.1), PSS
acpicpu6 at acpi0: C3(***@80 ***@0x20), C1(***@1 mwait.1), PSS
acpicpu7 at acpi0: C3(***@80 ***@0x20), C1(***@1 mwait.1), PSS
acpipwrres0 at acpi0: FN00, resource for FAN0
acpipwrres1 at acpi0: FN01, resource for FAN1
acpipwrres2 at acpi0: FN02, resource for FAN2
acpipwrres3 at acpi0: FN03, resource for FAN3
acpipwrres4 at acpi0: FN04, resource for FAN4
acpitz0 at acpi0: critical temperature is 106 degC
acpitz1 at acpi0: critical temperature is 106 degC
"INT3F0D" at acpi0 not configured
"IPI0001" at acpi0 not configured
acpibtn0 at acpi0: PWRB
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD01
acpivout at acpivideo0 not configured
acpivout at acpivideo0 not configured
acpivout at acpivideo0 not configured
acpivout at acpivideo0 not configured
acpivout at acpivideo0 not configured
acpivout at acpivideo0 not configured
acpivout at acpivideo0 not configured
ipmi at mainbus0 not configured
cpu0: Enhanced SpeedStep 3300 MHz: speeds: 3301, 3300, 3200, 3100, 2900,
2800, 2700, 2600, 2400, 2300, 2200, 2100, 2000, 1800, 1700, 1600 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Xeon E3-1200 v2 Host" rev 0x09
ppb0 at pci0 dev 1 function 0 "Intel Core 3G PCIE" rev 0x09: msi
pci1 at ppb0 bus 1
ppb1 at pci1 dev 0 function 0 "IDT 89HPES12N3A" rev 0x0e
pci2 at ppb1 bus 2
ppb2 at pci2 dev 2 function 0 "IDT 89HPES12N3A" rev 0x0e
pci3 at ppb2 bus 3
em0 at pci3 dev 0 function 0 "Intel 82571EB" rev 0x06: apic 2 int 19,
address 00:15:17:bc:a9:65
em1 at pci3 dev 0 function 1 "Intel 82571EB" rev 0x06: apic 2 int 18,
address 00:15:17:bc:a9:64
ppb3 at pci2 dev 4 function 0 "IDT 89HPES12N3A" rev 0x0e
pci4 at ppb3 bus 4
em2 at pci4 dev 0 function 0 "Intel 82571EB" rev 0x06: apic 2 int 17,
address 00:15:17:bc:a9:67
em3 at pci4 dev 0 function 1 "Intel 82571EB" rev 0x06: apic 2 int 16,
address 00:15:17:bc:a9:66
em4 at pci0 dev 25 function 0 "Intel 82579LM" rev 0x05: msi, address
00:25:90:a1:c0:19
ehci0 at pci0 dev 26 function 0 "Intel 6 Series USB" rev 0x05: apic 2
int 16
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "Intel EHCI root hub" rev
2.00/1.00 addr 1
ppb4 at pci0 dev 28 function 0 "Intel 6 Series PCIE" rev 0xb5: msi
pci5 at ppb4 bus 5
ppb5 at pci0 dev 28 function 4 "Intel 6 Series PCIE" rev 0xb5: msi
pci6 at ppb5 bus 6
em5 at pci6 dev 0 function 0 "Intel 82574L" rev 0x00: msi, address
00:25:90:a1:c0:18
ehci1 at pci0 dev 29 function 0 "Intel 6 Series USB" rev 0x05: apic 2
int 23
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev
2.00/1.00 addr 1
ppb6 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0xa5
pci7 at ppb6 bus 7
vga1 at pci7 dev 3 function 0 "Matrox MGA G200eW" rev 0x0a
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 31 function 0 "Intel C204 LPC" rev 0x05
ahci0 at pci0 dev 31 function 2 "Intel 6 Series AHCI" rev 0x05: msi,
AHCI 1.3
ahci0: port 0: 3.0Gb/s
ahci0: port 2: 3.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, WDC WD6401AALS-0, 05.0> SCSI3
0/direct fixed naa.50014ee002288208
sd0: 610480MB, 512 bytes/sector, 1250263728 sectors
sd1 at scsibus1 targ 2 lun 0: <ATA, WDC WD6400AAKS-7, 01.0> SCSI3
0/direct fixed naa.50014ee2adc0c1df
sd1: 610480MB, 512 bytes/sector, 1250263728 sectors
ichiic0 at pci0 dev 31 function 3 "Intel 6 Series SMBus" rev 0x05: apic
2 int 18
iic0 at ichiic0
sdtemp0 at iic0 addr 0x19: mcp98243
sdtemp1 at iic0 addr 0x1b: mcp98243
spdmem0 at iic0 addr 0x51: 8GB DDR3 SDRAM ECC PC3-12800 with thermal
sensor
spdmem1 at iic0 addr 0x53: 8GB DDR3 SDRAM ECC PC3-12800 with thermal
sensor
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
com2 at isa0 port 0x3e8/8 irq 5: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
wbsio0 at isa0 port 0x2e/2: NCT6776F rev 0x33
lm1 at wbsio0 port 0xa30/8: NCT6776F
vmm0 at mainbus0: VMX/EPT
uhub2 at uhub0 port 1 configuration 1 interface 0 "Intel Rate Matching
Hub" rev 2.00/0.00 addr 2
uhidev0 at uhub2 port 2 configuration 1 interface 0 "Winbond Electronics
Corp Hermon USB hidmouse Device" rev 1.10/0.01 addr 3
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons, Z dir
wsmouse0 at ums0 mux 0
uhidev1 at uhub2 port 2 configuration 1 interface 1 "Winbond Electronics
Corp Hermon USB hidmouse Device" rev 1.10/0.01 addr 3
uhidev1: iclass 3/1
ukbd0 at uhidev1: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhub3 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching
Hub" rev 2.00/0.00 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd2 at scsibus3 targ 1 lun 0: <OPENBSD, SR RAID 1, 006> SCSI2 0/direct
fixed
sd2: 610477MB, 512 bytes/sector, 1250258033 sectors
root on sd2a (391770920b7e6ed3.a) swap on sd2b dump on sd2b

[0] https://marc.info/?l=openbsd-tech&m=150298523506960&w=2
Gabriel Kihlman
2017-11-06 21:22:55 UTC
Permalink
Raw Message
Post by Atanas Vladimirov
First, sorry that I'm reporting this issue so late, but I spotted it
before a few days.
It seems that my surveillance webcam stopped to notify me via email
========
Nov 5 15:59:34 hodor smtpd[59494]: 2847e02c4337309e smtp
event=connected address=172.16.1.8 host=attic.bsdbg.net
Nov 5 15:59:35 hodor smtpd[59494]: 2847e02c4337309e smtp event=closed
address=172.16.1.8 host=attic.bsdbg.net reason="io-error: No SSL error"
========
I am also seeing this after upgrading to 6.2.

# grep -c "io-error: No SSL error" maillog
82
# zgrep -c "io-error: No SSL error" maillog.0.gz
999
# zgrep -c "io-error: No SSL error" maillog.1.gz
1152

..so pretty bad but I have not had the time or energy to debug it yet. I
am guessing the other side want to use old deprecated crypto in setting
up TLS since one of the mailservers that could not send mail to us is a
Solaris 10 machine probably using OpenSSL 0.9.8 or something.

Here is just the last half hour:

# grep "io-error: No SSL error" maillog
Nov 6 19:02:40 hekla smtpd[66969]: 59bb4c76df17549d smtp event=closed address=217.172.164.56 host=hera82.plusserver.de reason="io-error: No SSL error"
Nov 6 19:03:12 hekla smtpd[66969]: 59bb4c828b9c0d65 smtp event=closed address=195.149.155.133 host=mail3.distribution.cision.com reason="io-error: No SSL error"
Nov 6 19:08:47 hekla smtpd[66969]: 59bb4cf114121102 smtp event=closed address=195.149.155.133 host=mail3.distribution.cision.com reason="io-error: No SSL error"
Nov 6 19:10:38 hekla smtpd[66969]: 59bb4d17dc395021 smtp event=closed address=103.244.8.106 host=triton.nodens.net reason="io-error: No SSL error"
Nov 6 19:11:29 hekla smtpd[66969]: 59bb4d2239862abf smtp event=closed address=216.117.173.8 host=webbwise.com reason="io-error: No SSL error"
Nov 6 19:12:26 hekla smtpd[66969]: 59bb4d357a1c394a smtp event=closed address=125.206.111.91 host=lookup-net.co.jp reason="io-error: No SSL error"
Nov 6 19:13:19 hekla smtpd[66969]: 59bb4d526d94c7c2 smtp event=closed address=1.234.2.196 host=1.234.2.196 reason="io-error: No SSL error"
Nov 6 19:14:23 hekla smtpd[66969]: 59bb4d71d2816466 smtp event=closed address=195.149.155.133 host=mail3.distribution.cision.com reason="io-error: No SSL error"
Nov 6 19:14:53 hekla smtpd[66969]: 59bb4d8017cd6bf5 smtp event=closed address=113.105.139.87 host=113.105.139.87 reason="io-error: No SSL error"
Nov 6 19:17:09 hekla smtpd[66969]: 59bb4daa09d3216b smtp event=closed address=125.206.111.91 host=lookup-net.co.jp reason="io-error: No SSL error"
Nov 6 19:19:58 hekla smtpd[66969]: 59bb4df2ab8b156c smtp event=closed address=195.149.155.133 host=mail3.distribution.cision.com reason="io-error: No SSL error"
Nov 6 19:22:00 hekla smtpd[66969]: 59bb4e1757d1c409 smtp event=closed address=125.206.111.91 host=lookup-net.co.jp reason="io-error: No SSL error"
Nov 6 19:23:44 hekla smtpd[66969]: 59bb4e38a3d45d0d smtp event=closed address=46.59.120.29 host=smtp.partman.se reason="io-error: No SSL error"
Nov 6 19:25:34 hekla smtpd[66969]: 59bb4e4dcb29ab27 smtp event=closed address=195.149.155.133 host=mail3.distribution.cision.com reason="io-error: No SSL error"
Nov 6 19:28:15 hekla smtpd[66969]: 59bb4e8cc8bf02a2 smtp event=closed address=212.116.89.101 host=delta.webzoo.se reason="io-error: No SSL error"
Nov 6 19:28:15 hekla smtpd[66969]: 59bb4e8d20c633db smtp event=closed address=212.116.89.101 host=delta.webzoo.se reason="io-error: No SSL error"
Nov 6 19:29:51 hekla smtpd[66969]: 59bb4ea9c1fb4f50 smtp event=closed address=125.206.111.91 host=lookup-net.co.jp reason="io-error: No SSL error"
Nov 6 19:30:32 hekla smtpd[66969]: 59bb4eb47f60fa15 smtp event=closed address=216.117.173.8 host=webbwise.com reason="io-error: No SSL error"

/gabriel
Atanas Vladimirov
2017-12-20 16:51:33 UTC
Permalink
Raw Message
Post by Gabriel Kihlman
Post by Atanas Vladimirov
First, sorry that I'm reporting this issue so late, but I spotted it
before a few days.
It seems that my surveillance webcam stopped to notify me via email
========
Nov 5 15:59:34 hodor smtpd[59494]: 2847e02c4337309e smtp
event=connected address=172.16.1.8 host=attic.bsdbg.net
Nov 5 15:59:35 hodor smtpd[59494]: 2847e02c4337309e smtp event=closed
address=172.16.1.8 host=attic.bsdbg.net reason="io-error: No SSL error"
========
I am also seeing this after upgrading to 6.2.
# grep -c "io-error: No SSL error" maillog
82
# zgrep -c "io-error: No SSL error" maillog.0.gz
999
# zgrep -c "io-error: No SSL error" maillog.1.gz
1152
Hi,

After upgrade to:

OpenBSD 6.2-current (GENERIC.MP) #241: Sat Dec 2 12:41:37 MST 2017
***@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP

the problem seems to be fixed. I'm receiving the emails again.
Thanks,
Atanas

Loading...