Discussion:
net/unifi fails to start
(too old to reply)
Jordan Geoghegan
2018-12-08 07:49:04 UTC
Permalink
Hello,

I just got my hands on some Ubiquity kit, and I wanted to try running
the Unifi Controller software on OpenBSD. I installed the port (there's
no unifi package due to licence issues). When I start unifi (rcctl start
unifi) it seems to start ok, but unfortunately the web interface doesn't
actually load. When I look at the unifi logs, I see this error:
"<launcher> WARN system - cannot load native lib - ubnt_webrtc_jni"

I tried the lts and stable versions of the port on both OpenBSD 6.4 and
-current, both to no avail. Attached is the mongodb and unifi logs.

Has anyone had any luck running the unifi software on OpenBSD?

Any insight would be much appreciated.

Jordan
Joel A. Hänel
2018-12-08 08:33:40 UTC
Permalink
Hello.

Yes, I am running unifi-stable on OpenBSD 6.4-stable at my parents without any issues. It just works, so I cannot probably help you out.

You try to access the web interface over port 8080 or 8443?

Regards,
Joel Hänel
Post by Jordan Geoghegan
Has anyone had any luck running the unifi software on OpenBSD?
Jordan Geoghegan
2018-12-08 08:49:56 UTC
Permalink
Post by Joel A. Hänel
Hello.
Yes, I am running unifi-stable on OpenBSD 6.4-stable at my parents without any issues. It just works, so I cannot probably help you out.
You try to access the web interface over port 8080 or 8443?
Regards,
Joel Hänel
Post by Jordan Geoghegan
Has anyone had any luck running the unifi software on OpenBSD?
Huh, I just tried connecting to port 8080, and it automatically
redirects me to port 8443 and everything works. If I connect to port
8443 directly, I get some garbled characters on the page and nothing else.

Everything appears to be working now as long as I connect via port 8080.

My apologies for the noise.
Stuart Henderson
2018-12-08 21:33:21 UTC
Permalink
Post by Jordan Geoghegan
Post by Joel A. Hänel
Hello.
Yes, I am running unifi-stable on OpenBSD 6.4-stable at my parents without any issues. It just works, so I cannot probably help you out.
You try to access the web interface over port 8080 or 8443?
Regards,
Joel Hänel
Post by Jordan Geoghegan
Has anyone had any luck running the unifi software on OpenBSD?
Huh, I just tried connecting to port 8080, and it automatically
redirects me to port 8443 and everything works. If I connect to port
8443 directly, I get some garbled characters on the page and nothing else.
Any chance you could have connected to 8443 over http instead of https?
There is a check that warns if you do this (at least in unifi 5.9.x - I don't
have an older install handy to check) but I guess it might not work in all cases.

The logged error you mention is normal and expected, there are a couple of
binary-only modules - libubnt_sdnotify_jni.so and libubnt_webrtc_jni.so -
where only Linux/Windows/MacOS versions are provided and source is not
available, but most things still work fine without them. (there's another
java module, the "snappy" compressor, which includes .so modules and
an OpenBSD build isn't included upstream, so the port uses a version
which I've built instead).

Loading...