Discussion:
Status of X i386 openbsd 6.2 on x200
(too old to reply)
flipchan
2018-04-01 21:41:07 UTC
Permalink
Hello all,

I have tried to installed 6.1 and 6.2 on a thinkpad x200 it works but X does work ...

Its works great with 6.0 but then i dont get the good 6.2 packages and features such as syspatch.


It seems lika well known problem:
https://marc.info/?l=openbsd-bugs&m=150506076421862&w=2


Does anyone know the status of this/ if anyone is working on this ?
--
Take Care Sincerely flipchan layerprox dev
Dumitru Mișu Moldovan
2018-04-02 08:19:55 UTC
Permalink
Post by flipchan
Hello all,
I have tried to installed 6.1 and 6.2 on a thinkpad x200 it works but X does work ...
Its works great with 6.0 but then i dont get the good 6.2 packages and features such as syspatch.
https://marc.info/?l=openbsd-bugs&m=150506076421862&w=2
According to Wikipedia, X200 uses a Penryn Core 2 Duo. Have you tried
an amd64 image? That would be better suited to this machine. I have a
similar HP notebook from the same era, running 6.3beta with only minor
issues (no two finger scrolling for the touchpad and an 80x25 console).

Also running i386 on an old Atom, with absolutely no hardware issues,
for what it's worth

Christophe Simon
2018-04-02 09:11:44 UTC
Permalink
I can confirm that amd64 runs perfectly on the X200.

I have an X200s, and both 6.2 -stable and 6.3 -current ran X without issue.
Post by flipchan
Post by flipchan
Hello all,
I have tried to installed 6.1 and 6.2 on a thinkpad x200 it works but
X does work ...
Post by flipchan
Its works great with 6.0 but then i dont get the good 6.2 packages
and features such as syspatch.
Post by flipchan
https://marc.info/?l=openbsd-bugs&m=150506076421862&w=2
According to Wikipedia, X200 uses a Penryn Core 2 Duo. Have you tried
an amd64 image? That would be better suited to this machine. I have a
similar HP notebook from the same era, running 6.3beta with only minor
issues (no two finger scrolling for the touchpad and an 80x25 console).
Also running i386 on an old Atom, with absolutely no hardware issues,
for what it's worth…
--
Envoyé de mon appareil Android avec K-9 Mail. Veuillez excuser ma brièveté.
oneroi.org.uk
2018-04-02 13:58:43 UTC
Permalink
On Mon, 02 Apr 2018 11:11:44 +0200
Post by Christophe Simon
I can confirm that amd64 runs perfectly on the X200.
I have an X200s, and both 6.2 -stable and 6.3 -current ran X without issue.
Agreed - no problems for me either.
Markus Lude
2018-04-02 19:26:58 UTC
Permalink
Post by flipchan
Hello all,
I have tried to installed 6.1 and 6.2 on a thinkpad x200 it works but X does work ...
Its works great with 6.0 but then i dont get the good 6.2 packages and features such as syspatch.
https://marc.info/?l=openbsd-bugs&m=150506076421862&w=2
Does anyone know the status of this/ if anyone is working on this ?
The problem still exists. The drm diff back then was quite huge and I am
unable to break it down in smaller chunks to see where the cause therein
is.
The T61 is quite old and still runs with 6.1.
It is new for me that newer Thinkpads do have the same problem. Could
you please post a trace of your crash?

Regards,
Markus
flipchan
2018-04-04 22:23:57 UTC
Permalink
The amd64 fs file for 6.2 is working good i know got it running with libreboot which is cool, libreboot doesnt support full disk encryption which sucks but i am glad that it works .
Post by flipchan
Post by flipchan
Hello all,
I have tried to installed 6.1 and 6.2 on a thinkpad x200 it works but
X does work ...
Post by flipchan
Its works great with 6.0 but then i dont get the good 6.2 packages
and features such as syspatch.
Post by flipchan
https://marc.info/?l=openbsd-bugs&m=150506076421862&w=2
Does anyone know the status of this/ if anyone is working on this ?
The problem still exists. The drm diff back then was quite huge and I am
unable to break it down in smaller chunks to see where the cause therein
is.
The T61 is quite old and still runs with 6.1.
It is new for me that newer Thinkpads do have the same problem. Could
you please post a trace of your crash?
Regards,
Markus
--
Take Care Sincerely flipchan layerprox dev
Jordan Geoghegan
2018-04-05 16:39:56 UTC
Permalink
What is it that prevents full disk encryption? I have been wanting a
libreboot machine for travel, but Full disk encryption is more important
that a clean bios when travelling.

Thanks for your time,

Jordan
Post by flipchan
The amd64 fs file for 6.2 is working good i know got it running with libreboot which is cool, libreboot doesnt support full disk encryption which sucks but i am glad that it works .
Post by flipchan
Post by flipchan
Hello all,
I have tried to installed 6.1 and 6.2 on a thinkpad x200 it works but
X does work ...
Post by flipchan
Its works great with 6.0 but then i dont get the good 6.2 packages
and features such as syspatch.
Post by flipchan
https://marc.info/?l=openbsd-bugs&m=150506076421862&w=2
Does anyone know the status of this/ if anyone is working on this ?
The problem still exists. The drm diff back then was quite huge and I am
unable to break it down in smaller chunks to see where the cause therein
is.
The T61 is quite old and still runs with 6.1.
It is new for me that newer Thinkpads do have the same problem. Could
you please post a trace of your crash?
Regards,
Markus
flipchan
2018-04-05 18:10:03 UTC
Permalink
It works when installing but it wont boot



On their website it says: "
Installing OpenBSD with full disk encryption

Not working. You can modify the above procedure (installation w/o encryption) to install OpenBSD using full disk encryption, and it appears to work, except that it’s not yet clear how to actually boot an OpenBSD+FDE installation using libreboot+Grub2. If you get it working, please let us know."

Site: https://libreboot.org/docs/bsd/openbsd.html
Post by Jordan Geoghegan
What is it that prevents full disk encryption? I have been wanting a
libreboot machine for travel, but Full disk encryption is more
important
that a clean bios when travelling.
Thanks for your time,
Jordan
Post by flipchan
The amd64 fs file for 6.2 is working good i know got it running with
libreboot which is cool, libreboot doesnt support full disk encryption
which sucks but i am glad that it works .
Post by flipchan
Post by flipchan
Post by flipchan
Hello all,
I have tried to installed 6.1 and 6.2 on a thinkpad x200 it works
but
Post by flipchan
Post by flipchan
X does work ...
Post by flipchan
Its works great with 6.0 but then i dont get the good 6.2 packages
and features such as syspatch.
Post by flipchan
https://marc.info/?l=openbsd-bugs&m=150506076421862&w=2
Does anyone know the status of this/ if anyone is working on this ?
The problem still exists. The drm diff back then was quite huge and
I
Post by flipchan
Post by flipchan
am
unable to break it down in smaller chunks to see where the cause therein
is.
The T61 is quite old and still runs with 6.1.
It is new for me that newer Thinkpads do have the same problem.
Could
Post by flipchan
Post by flipchan
you please post a trace of your crash?
Regards,
Markus
--
Take Care Sincerely flipchan layerprox dev
Markus Lude
2018-04-14 14:19:26 UTC
Permalink
Post by Markus Lude
Post by flipchan
Hello all,
I have tried to installed 6.1 and 6.2 on a thinkpad x200 it works but X does work ...
Its works great with 6.0 but then i dont get the good 6.2 packages and features such as syspatch.
https://marc.info/?l=openbsd-bugs&m=150506076421862&w=2
Does anyone know the status of this/ if anyone is working on this ?
The problem still exists. The drm diff back then was quite huge and I am
unable to break it down in smaller chunks to see where the cause therein
is.
The T61 is quite old and still runs with 6.1.
It is new for me that newer Thinkpads do have the same problem. Could
you please post a trace of your crash?
I now moved from i386 to amd64 on the T61. I didn't saw the drm related
crash since then. Upgrade through 6.2 to 6.3 worked.

Regards,
Markus

Loading...