Adriano Barbosa
2021-05-03 14:15:13 UTC
Hi misc@,
I have a SanDisk 16GB Class 4 SD card which I can complete the install
process on my Raspberry Pi 3 Model B v1.2 and another SanDisk Ultra
32GB Class 10 which can't complete the install. Tried the install on
6.8 and 6.9. The 32GB card seems to be fine (tested with Ubuntu
install for a few days). Is that a known issue? Any workaround?
In the past when the SD card reader didn't work I had a similar issue
trying to install on a Kingston flash drive related to [1] according
to [2]. Any relation?
[1] https://www.raspberrypi.org/blog/pi-3-booting-part-i-usb-mass-storage-boot/
[2] https://undeadly.org/cgi?action=article&sid=20170409123528
#
# SanDisk 16GB Class 4 info on working install
#
$ doas disklabel -h /dev/sd0c
# /dev/sd0c:
type: SCSI
disk: SCSI disk
label: SD/MMC SU16G
duid: f8222dcf9beba562
flags:
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 255
sectors/cylinder: 16065
cylinders: 1936
total sectors: 31116288 # total bytes: 15193.5M
boundstart: 65536
boundend: 31116288
drivedata: 0
#
# SanDisk Ultra 32GB Class 10 during install
#
(I)nstall, (U)pgrade, (A)utoinstall or (S)hell? s
# cd /dev
# sh MAKEDEV sd0
# disklabel -h sd0
# /dev/rsd0c:
type: vnd
disk: vnd device
label: fictitious
duid: f90b6bb35b8cfb39
flags:
bytes/sector: 512
sectors/track: 100
tracks/cylinder: 1
sectors/cylinder: 100
cylinders: 880
total sectors: 60751872 # total bytes: 29664.0M
boundstart: 49152
boundend: 88064
drivedata: 0
16 partitions:
# size offset fstype [fsize bsize cpg]
a: 19.0M 49152 4.2BSD 2048 16384 1216
c: 29664.0M 0 unused
i: 8.0M 32768 MSDOS
# install
...
Available disks are: sd0.
Which disk is the root disk? ('?' for details) [sd0] ?
sd0: SD/MMC, SL32G, 0030 (29.0G)
Available disks are: sd0.
Which disk is the root disk? ('?' for details) [sd0]
Disk: sd0 geometry: 3781/255/63 [60751872 Sectors]
Offset: 0 Signature: 0xAA55
Starting Ending LBA Info:
#: id C H S - C H S [ start: size ]
-------------------------------------------------------------------------------
*0: 0C 2 10 9 - 3 15 12 [ 32768: 16384 ] FAT32L
1: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
2: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
3: A6 3 15 13 - 5 122 53 [ 49152: 38912 ] OpenBSD
Use (W)hole disk or (E)dit the MBR? [whole]
Creating a msdos partition and an OpenBSD partition for rest of sd0...done.
/dev/rsd0i: 32668 sectors in 8167 FAT16 clusters (2048 bytes/cluster)
bps=512 spc=4 res=1 nft=2 rde=512 mid=0xf8 spf=32 spt=63 hds=255
hid=32768 bsec=32768
The auto-allocated layout for sd0 is:
# size offset fstype [fsize bsize cpg]
a: 1024.0M 65536 4.2BSD 2048 16384 1 # /
b: 1165.3M 2162688 swap
c: 29664.0M 0 unused
d: 1628.0M 4549312 4.2BSD 2048 16384 1 # /tmp
e: 2530.5M 7883424 4.2BSD 2048 16384 1 # /var
f: 3385.0M 13065888 4.2BSD 2048 16384 1 # /usr
g: 949.5M 19998368 4.2BSD 2048 16384 1 # /usr/X11R6
h: 3851.5M 21942944 4.2BSD 2048 16384 1 # /usr/local
i: 16.0M 32768 MSDOS
j: 1677.0M 29830816 4.2BSD 2048 16384 1 # /usr/src
k: 5874.0M 33265312 4.2BSD 2048 16384 1 # /usr/obj
l: 7547.2M 45295264 4.2BSD 2048 16384 1 # /home
Use (A)uto layout, (E)dit auto layout, or create (C)ustom layout? [a]
/dev/rsd0a: 1024.0MB in 2097152 sectors of 512 bytes
6 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each
newfs: wtfs: write error on block 192: Input/output error
newfs: 20e419e02833a06a.l: No such file or directory
newfs: 20e419e02833a06a.d: No such file or directory
newfs: 20e419e02833a06a.f: No such file or directory
newfs: 20e419e02833a06a.g: No such file or directory
newfs: 20e419e02833a06a.h: No such file or directory
newfs: 20e419e02833a06a.k: No such file or directory
newfs: 20e419e02833a06a.j: No such file or directory
newfs: 20e419e02833a06a.e: No such file or directory
mount_ffs: 20e419e02833a06a.a on /mnt: No such file or directory
mount_ffs: 20e419e02833a06a.l on /mnt/home: No such file or directory
mount_ffs: 20e419e02833a06a.d on /mnt/tmp: No such file or directory
mount_ffs: 20e419e02833a06a.f on /mnt/usr: No such file or directory
mount_ffs: 20e419e02833a06a.g on /mnt/usr/X11R6: No such file or directory
mount_ffs: 20e419e02833a06a.h on /mnt/usr/local: No such file or directory
mount_ffs: 20e419e02833a06a.k on /mnt/usr/obj: No such file or directory
mount_ffs: 20e419e02833a06a.j on /mnt/usr/src: No such file or directory
mount_ffs: 20e419e02833a06a.e on /mnt/var: No such file or directory
WARNING! The following filesystems were not properly mounted:
/mnt (20e419e02833a06a.a)
/mnt/home (20e419e02833a06a.l)
/mnt/tmp (20e419e02833a06a.d)
/mnt/usr (20e419e02833a06a.f)
/mnt/usr/X11R6 (20e419e02833a06a.g)
/mnt/usr/local (20e419e02833a06a.h)
/mnt/usr/obj (20e419e02833a06a.k)
/mnt/usr/src (20e419e02833a06a.j)
/mnt/var (20e419e02833a06a.e)
Continue anyway? [no] !
rpi# disklabel -h sd0
disklabel: /dev/rsd0c: Input/output error
I have a SanDisk 16GB Class 4 SD card which I can complete the install
process on my Raspberry Pi 3 Model B v1.2 and another SanDisk Ultra
32GB Class 10 which can't complete the install. Tried the install on
6.8 and 6.9. The 32GB card seems to be fine (tested with Ubuntu
install for a few days). Is that a known issue? Any workaround?
In the past when the SD card reader didn't work I had a similar issue
trying to install on a Kingston flash drive related to [1] according
to [2]. Any relation?
[1] https://www.raspberrypi.org/blog/pi-3-booting-part-i-usb-mass-storage-boot/
[2] https://undeadly.org/cgi?action=article&sid=20170409123528
#
# SanDisk 16GB Class 4 info on working install
#
$ doas disklabel -h /dev/sd0c
# /dev/sd0c:
type: SCSI
disk: SCSI disk
label: SD/MMC SU16G
duid: f8222dcf9beba562
flags:
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 255
sectors/cylinder: 16065
cylinders: 1936
total sectors: 31116288 # total bytes: 15193.5M
boundstart: 65536
boundend: 31116288
drivedata: 0
#
# SanDisk Ultra 32GB Class 10 during install
#
(I)nstall, (U)pgrade, (A)utoinstall or (S)hell? s
# cd /dev
# sh MAKEDEV sd0
# disklabel -h sd0
# /dev/rsd0c:
type: vnd
disk: vnd device
label: fictitious
duid: f90b6bb35b8cfb39
flags:
bytes/sector: 512
sectors/track: 100
tracks/cylinder: 1
sectors/cylinder: 100
cylinders: 880
total sectors: 60751872 # total bytes: 29664.0M
boundstart: 49152
boundend: 88064
drivedata: 0
16 partitions:
# size offset fstype [fsize bsize cpg]
a: 19.0M 49152 4.2BSD 2048 16384 1216
c: 29664.0M 0 unused
i: 8.0M 32768 MSDOS
# install
...
Available disks are: sd0.
Which disk is the root disk? ('?' for details) [sd0] ?
sd0: SD/MMC, SL32G, 0030 (29.0G)
Available disks are: sd0.
Which disk is the root disk? ('?' for details) [sd0]
Disk: sd0 geometry: 3781/255/63 [60751872 Sectors]
Offset: 0 Signature: 0xAA55
Starting Ending LBA Info:
#: id C H S - C H S [ start: size ]
-------------------------------------------------------------------------------
*0: 0C 2 10 9 - 3 15 12 [ 32768: 16384 ] FAT32L
1: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
2: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
3: A6 3 15 13 - 5 122 53 [ 49152: 38912 ] OpenBSD
Use (W)hole disk or (E)dit the MBR? [whole]
Creating a msdos partition and an OpenBSD partition for rest of sd0...done.
/dev/rsd0i: 32668 sectors in 8167 FAT16 clusters (2048 bytes/cluster)
bps=512 spc=4 res=1 nft=2 rde=512 mid=0xf8 spf=32 spt=63 hds=255
hid=32768 bsec=32768
The auto-allocated layout for sd0 is:
# size offset fstype [fsize bsize cpg]
a: 1024.0M 65536 4.2BSD 2048 16384 1 # /
b: 1165.3M 2162688 swap
c: 29664.0M 0 unused
d: 1628.0M 4549312 4.2BSD 2048 16384 1 # /tmp
e: 2530.5M 7883424 4.2BSD 2048 16384 1 # /var
f: 3385.0M 13065888 4.2BSD 2048 16384 1 # /usr
g: 949.5M 19998368 4.2BSD 2048 16384 1 # /usr/X11R6
h: 3851.5M 21942944 4.2BSD 2048 16384 1 # /usr/local
i: 16.0M 32768 MSDOS
j: 1677.0M 29830816 4.2BSD 2048 16384 1 # /usr/src
k: 5874.0M 33265312 4.2BSD 2048 16384 1 # /usr/obj
l: 7547.2M 45295264 4.2BSD 2048 16384 1 # /home
Use (A)uto layout, (E)dit auto layout, or create (C)ustom layout? [a]
/dev/rsd0a: 1024.0MB in 2097152 sectors of 512 bytes
6 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each
newfs: wtfs: write error on block 192: Input/output error
newfs: 20e419e02833a06a.l: No such file or directory
newfs: 20e419e02833a06a.d: No such file or directory
newfs: 20e419e02833a06a.f: No such file or directory
newfs: 20e419e02833a06a.g: No such file or directory
newfs: 20e419e02833a06a.h: No such file or directory
newfs: 20e419e02833a06a.k: No such file or directory
newfs: 20e419e02833a06a.j: No such file or directory
newfs: 20e419e02833a06a.e: No such file or directory
mount_ffs: 20e419e02833a06a.a on /mnt: No such file or directory
mount_ffs: 20e419e02833a06a.l on /mnt/home: No such file or directory
mount_ffs: 20e419e02833a06a.d on /mnt/tmp: No such file or directory
mount_ffs: 20e419e02833a06a.f on /mnt/usr: No such file or directory
mount_ffs: 20e419e02833a06a.g on /mnt/usr/X11R6: No such file or directory
mount_ffs: 20e419e02833a06a.h on /mnt/usr/local: No such file or directory
mount_ffs: 20e419e02833a06a.k on /mnt/usr/obj: No such file or directory
mount_ffs: 20e419e02833a06a.j on /mnt/usr/src: No such file or directory
mount_ffs: 20e419e02833a06a.e on /mnt/var: No such file or directory
WARNING! The following filesystems were not properly mounted:
/mnt (20e419e02833a06a.a)
/mnt/home (20e419e02833a06a.l)
/mnt/tmp (20e419e02833a06a.d)
/mnt/usr (20e419e02833a06a.f)
/mnt/usr/X11R6 (20e419e02833a06a.g)
/mnt/usr/local (20e419e02833a06a.h)
/mnt/usr/obj (20e419e02833a06a.k)
/mnt/usr/src (20e419e02833a06a.j)
/mnt/var (20e419e02833a06a.e)
Continue anyway? [no] !
rpi# disklabel -h sd0
disklabel: /dev/rsd0c: Input/output error
--
Adriano Barbosa
Adriano Barbosa